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19. Use CVIPtools to explore the standard histogram operations on a color image. Select a color image of your choice and do the following: a) Display the histogram by selecting File->Show  Histogram, or by clicking the histogram icon which looks like a tiny bar graph, b) Use Enhancement->Histogram/Contrast->Histogram Equalization to perform a histogram equalization four times, each time selecting a different band to use (Value, Red, Green and Blue), and display the histograms. What band does the parameter selection Value use? Explain. c) Perform a histogram slide up by 50 and down by 50 and display the histograms, verify the results are correct, d) perform a histogram stretch without clipping (set to 0), and with 0.025% clipping on both ends, display the histograms – are they correct? e) Perform a histogram shrink to the range [1,100], display the histogram and verify it is correct.
20. Use CVIPtools to explore histogram specification. Use Enhancement->Histogram/Contrast->Histogram Specification. Select a monochrome of your choice and do the following: a) Display the histogram by selecting File->Show  Histogram, or by clicking the histogram icon which looks like a tiny bar graph, b) use the default sin(0.025*x) for the Formula, and look at the histograms – does the output look like the specified histogram, why or why not?, c) change the Formula to sin(0.25*x), and look at the histograms – does the output look like the specified histogram, why or why not?, d) change the Formula to sin(0.005*x), and look at the histograms – does the output look like the specified histogram, why or why not?, e) change the Formula to ramp(2.0x+5), and look at the histograms – does the output look like the specified histogram, why or why not? Does it look like any of the other specified histograms? f) Experiment with the other formulas, especially the log and exp. After your experimentation can you draw any general conclusions regarding histogram specification? g) Select a color image of your choice and repeat (a)-(f). With the color image experiment with using different Formulas for each band.
21. Given the following 5×5 subimage (using 5×5 as the window size) from an image with 3 bits per pixel and average gray value of  6, find the resulting value for the center pixel by letting k1 = 0.8 and k2 = 0.2 and applying the following filters: a) ACE, 2) ACE2, 3) log-ACE, 4) exp-ACE.


22. Use CVIPtools to explore the ACE filters. Open the image in figure 8.2-20a and use the ACE filters to create the images in Figures 8.2-20, 21, 22, and 23.
23. a) Why use pseudocolor?, b) list the two domains in which pseudocolor is performed and describe a method in each.
24. Given the following 4-bit per pixel image, create a pseudocolor image by applying intensity slicing. Divide the gray level range into 4 equal regions and map the low range to bright red, the next bright green, the next bright blue and the next to bright yellow (red+green). Express the image as a 5×5 matrix with a triple at each pixel locations for the RGB values.


25. Use CVIPtools to explore pseudocolor. Select a monochrome image of your choice and: a) Select Gray Level Mapping and perform the operation with the default values, b) change the shape of the mapping equations so they are all the same – how does the image appear? Change to a different shape, but make them all the same, how does the image appear now? c) Select Intensity Slicing and apply it with the default parameter values. How do the colors compare to the results from (a)? d) Change the input ranges so that the entire 0-255 range is not covered and apply the operation both with and without Set Out of Range Data to 0 selected. Are the results what you expected? Can you think of an application where this parameter is useful? e) Experiment with changing the output colors. What colors do you add to create yellow? Purple? Cyan? After your experimentation can you draw any general conclusions?
26. Use CVIPtools to explore pseudocolor in the frequency domain. a) Select Frequency Domain Mapping and apply with the default values – what colors are most prominent? b) Change the colors from RGB order to BRG order. How does this affect the colors you see in the output image? c) Experiment with changing the cutoff frequencies. After your experimentation can you draw any general conclusions?
27. Use CVIPtools to explore pseudocolor with Enhancement->Pseudocolor->Gray level mapping II. This function provides a graphical interface and more options than the one explored in exercise #25.  Select a monochrome image of your choice and: a) Select Gray Level Mapping II and click on the Custom Remap Curve button, which will display a new window for you to enter your mapping curves. Select the red band and use the left mouse button to input new points, and the right mouse button to delete points. The data points can also be dragged with the left mouse button. Points can also be entered manually by inputting the (X,Y) values and clicking the Add button. Next, create curves for the green and blue bands, then select All, which will show you the mapping curves. Select the interpolation method desired and use the Save button to save your mapping file. Note that the default directory for the mapping files is in $CVIPtools\bin\remap. Next press Apply on the enhancement window to perform the pseudocolor operation. b) View the histogram for your pseudocolor image, can you see any correlation between it and the mapping equations? c) Experiment with creating different mapping equations and viewing the output images and their histograms. In general, can you see any correlation between the histograms and the mapping equations? d) Apply the mapping files you have created to other images with the Open a map file or the Load Mapping File option. Compare the results from using the same mapping file to different images. Are they similar? Why or why not?
28. Many image sharpening algorithms consist of three basic steps, what are they? Provide an example operation for each step.
29. Use CVIPtools to explore the high boost spatial filter. Open the image in Figure 8.3-2a and create the images in 8.3-2b-g. 
30. Use CVIPtools to develop your own image sharpening algorithm. Select an image that you want to sharpen (if you cannot find one, then use a good image and slightly blur it with Utilities->Filter->Specify a Blur). Be sure to examine the histograms of your output images during development. a) Use Analysis->Transforms to extract a phase only image. Develop your own sharpening algorithm by using this image and the original image. b) Use Analysis->Edge/Line Detection to generate edge only images. Develop your own sharpening algorithm by using these images and the original image. c) Use Utilities->Filter->Difference Filter to generate images. Develop your own sharpening algorithm by using these images and the original image. d) After your algorithm development can you draw any general conclusions?
31. a) What is the image model used for homomorphic filtering? b) List the steps in the homomorphic filtering process. c) Explain how the filter shown in Figure 8.3-5 relates to the model defined in (a).
32.  Use CVIPtools to explore homomorphic filtering. Open the image in Figure 8.3-6a and create the image in b. Experiment with varying the parameters. Can you obtain better results than shown in the figure?
33. a) Explain the historical reasons underlying the development of the unsharp masking algorithm. b) Describe and explain the steps in the algorithm.
34. Use CVIPtools to explore unsharp masking. Open the image in Figure 8.3-8a and create the images in b-f. Experiment with varying the parameters. After your experimentation can you draw any general conclusions?
35. Use CVIPtools to explore Sharpening Algorithms I and II. Open the image in Figure 8.3-9a. a) Create the images in b,c,d. b) Create the images in Figure 8.3-10b,c,d. c) Use these two algorithms and experiment with varying the parameters. d) Based on what you have learned develop your own sharpening algorithm. How do your results compare to the results from Sharpening Algorithms I&II and/or the algorithms you developed in exercise #30?
36. a) List two reasons for image smoothing. b) In general, how is image smoothing accomplished?
37. a) Describe convolution masks used for image smoothing. In general, what can be said about the mask coefficients? b) What is the primary difference in the results from an arithmetic mean compared to a Gaussian spatial filter? c) With arithmetic mean filters the results can be normalized by dividing by the sum of the mask coefficients. What is another method to accomplish this? d) What happens as the filter mask size is increased?
38. a) How would you describe an image that has been smoothed by a median filter with a relatively large mask? b) Since median filtering is computationally intensive, what is an alternative that is more efficient, but gives similar results?
39. Explain why the results are different if we use an FFT and a DCT for lowpass frequency domain smoothing, even though we use the same cutoff frequency for the filter.
40. Use CVIPtools to explore image smoothing. a) Use the FFT smoothing and the mean filter. Experiment with varying the parameters until the output images look similar. Go to Analysis->Transforms and perform an FFT on the similar looking output images. Do the spectra look similar? Why or why not? b) Perform the operations in (a), but use the Yp-mean and the midpoint filter. c) Perform the operations in (a), but use the Gaussian and the contra-harmonic filter. d) After your experimentation can you draw any general conclusions?
1.  Find the pseudo-median value for the center pixel, using a 3×3 window, for the following 3×3 subimages:
a)         b)      c)      d) 
 2.  Apply the Kuwahara filter to the following with L = 1. For each subimage find the resulting value of the center pixel.



a)  		b)  	c) 
3. Given the following tables of an image histogram and a specified histogram, find the mapping tables and the resulting histogram after histogram specification process is performed. Note: do not round histogram equalized values until final mapping table to avoid ambiguities.
	Image Histogram

	 Gray value
	Number of pixels

	 0
	10

	1
	5

	2
	5

	3
	11

	4
	5

	5
	0

	6
	3

	7
	6

	Specified Histogram

	Gray value
	Number of pixels

	 0
	5

	1
	5

	2
	5

	3
	10

	4
	10

	5
	5

	6
	5

	7
	0



4. Use CVIPtools to explore local histogram equalization. Load a monochrome and a color image of your choice. a) Using the monochrome image what do you observe as you increase the block size? b) What do you observe when you add the local equalized image output to the original? c) Apply the local histogram equalization to the color image. Use a block size of 16 and vary the band parameter – value, red, green and blue. Which one works the best? d) Repeat (c) on a different color image. Are the results the same? Why or why not?
5. Explore CVIPtools using the Utilities->Enhance selections. If you were selecting commonly used enhancement methods for Utilities are these the most useful? Why or why not? Explain.
18. a) At high frequencies noise may obscure the image signal when using an inverse filter. Explain why. b) What can be done to help solve this problem?
19. a) What is the power spectrum ratio and how is it related to the signal-to-noise ratio? b) Sketch the filter response of the Wiener and the inverse filter and explain why the Wiener works better in the presence of noise. c) Why use a constant in place of the power spectrum ratio in the Wiener filter?
20. Use CVIPtools to explore the inverse and the Wiener filter. Use Restoration->Frequency Filters and Utilities->Create->Add Noise and Utilities->Filter->Specify a Blur. Select a square image that is an even power of 2, for example 256×256 or 512×512. a) Blur the image to simulate motion blur along the column axis, using the following parameters: 7×7 mask, horizontal line for blur shape, blur method constant, and weight = 1.0. Compare results of using the Wiener and the inverse filters on the blurry image. For the degradation function, select Specify a function and set the parameters the same as with the blur. For the Wiener use Utilities->Create->Black Image to create a black image to be used as the noise image (since we did not add noise). Experiment with setting the cutoff frequency and the gain limit to obtain good results. b) Use the blurry image and add zero-mean Gaussian noise with a variance of 100. Also, with Utilities->Create->Noise select Use a black image to create the noise image. Compare results of using the Wiener and the inverse filters. For the degradation function, select Specify a function and set the parameters the same as with the blur. For the Wiener use the noise image you created. Experiment with setting the cutoff frequency and the gain limit to obtain good results. Compare your results to part (a). c) Repeat (b) but add noise with a variance of 800. How do the results compare?
21. a) Explain why the CLS filter may give better results than the Wiener filter. b) Use CVIPtools and apply the CLS filter to the images you created in exercise #20. c) Compare the results of the CLS and Wiener filter. Did it perform as you expected? Why or why not?
22. Repeat Exercise #20, but for the blur use a Gaussian circle to simulate a poorly focused lens.
23. a) Write the equation for the geometric mean filter. What are the values for α and γ to create b) power spectrum equalization filter?, c) parametric Wiener filter?, d) standard Wiener filter?, e) inverse filter?
24. Repeat exercise #20 with the practical Wiener and the parametric Wiener filters. Can you get results as good, or better, than with the standard Wiener? Why or why not?
25. Repeat exercise #20 with the geometric mean and the power spectrum equalization filters. With the geometric mean try various values for α and γ. Can you get results as good, or better, than with the standard Wiener filter? Why or why not?
26. a) What type of processing is normally done for adaptive filtering in the frequency domain? b) What is the blocking effect and what causes it? c) What are two methods for dealing with the blocking effect?
27. Use CVIPtools to explore bandpass, bandreject and notch filters. a) Use image 9.5-10 and try to do a better restoration than in the figure. b) Select an image of your choice and experiment with adding sine wave and cosine wave images at various frequencies to the image. Use Utilities->Create and Utilities->Arith/Logic. Next, use notch and bandreject filters to try to remove the periodic noise. Use the bandpass filter to extract noise only images and examine the spectrum of these images to gain insight into the process.
28. a) What are the two steps in geometric transforms? b) Explain why the second step is necessary. c) What are the advantages and disadvantages of the three types of gray level interpolation?


29. Given the following 16×16 distorted image, , and the mapping equations,  restore the 3x3 subimage where the row and column coordinates are between 0 and 2. That is, find the subimage represented by the x’s.

		






30. Given the following 16×16 distorted image, , and the mapping equations,  restore the 3×3 subimage where the row and column coordinates are between 0 and 2. That is, find the subimage represented by the x’s. Use a) nearest neighbor, b) neighborhood average using the four edge neighbors (horizontal and vertical)

		




31. Given that we have found the mapping equations for a quadrilateral and determined the following corresponding pixel coordinates:
	(r,c) coordinates for the restored image
	
Corresponding  coordinates found by the mapping equations

	(4,3)
	(1.2,2.1)

	(4,4)
	(1.3,2.6)

	(5,3)
	(1.8,2.2)

	(5,4)
	(1.9,2.8)



a) Use the following degraded image and find the bilinear interpolation equation needed to find the x’s in the following restored image, b) apply the equation and find the values for the x’s:


32. Use CVIPtools, Restoration->Geometric Transforms, to explore geometric transforms and restoration. Select an image to distort and restore. a) Create a 5×5 warping mesh by selecting the Create Mesh button, inputting 5 for the Number of rows and the Number of columns will automatically be set to 5. Next, input Regular->Irregular for the Direction and bilinear interpolation for the Gray value interpolation method.  Now select the points for the mesh with the mouse by holding the Alt key on the keyboard and clicking the left mouse button. b) Click Apply to distort the image, c) Restore the image by selection Irregular->Regular for the direction. Do this three times, each time selecting a different Gray level interpolation method. Compare the results with each of the methods, which one is best? What type of artifacts do you observe? On your computer is the relative speed of each method noticeable? 
33. Use CVIPtools, Restoration->Geometric Transforms, to explore geometric transforms and restoration. Select an image to distort and restore. a) Create a 7×7 warping mesh by selecting the Create Mesh button, inputting 7 for the Number of rows and 7 for the Number of columns. Next, input Irregular->Regular for the Direction and bilinear interpolation for the Gray value interpolation method.  Now select the points for the mesh with the mouse by holding the control key on the keyboard and clicking the left mouse button. b) Click Apply to distort the image, c) Restore the image by selection Regular->Irregular for the direction. Do this three times, each time selecting a different Gray level interpolation method. Compare the results with each of the methods, which one is best? What type of artifacts do you observe? On your computer is the relative speed of each method noticeable? 
1. Apply the adaptive median filter to the center pixel (199) in the following subimage, using a maximum window size of 9×9.

2. Apply the adaptive median filter to the center pixel (199) in the following subimage, using a maximum window size of 9×9.

3. Apply the adaptive median filter to the center pixel (255) in the following subimage, using a maximum window size of 9×9.

4. a) Are noise only images typically stationary? Use CVIPtools to create noise images and verify your answer. b) Are typical, real images stationary? Use CVIPtools to verify. Include screen shots of spectra to illustrate your verification.
5. Find the Radon transform, using θ as shown in Figure 9.7-4, of the following image at
 θ = a) 0◦, b) 45◦, and c) 90◦.  Assume the image is zero padded elsewhere.
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